• 赤色のリンクは、まだ日本語Codexに存在しないページ・画像です。英語版と併せてご覧ください。(詳細

このWikiはいつでも誰でも編集できます

「PHP バージョンの更新」の版間の差分

提供: WordPress Codex 日本語版
移動先: 案内検索
(最新英語版を反映 https://wordpress.org/support/update-php/)
 
(和訳完了)
1行目: 1行目:
'''Your WordPress site can be faster, and more secure, and you can make this happen!'''
+
'''WordPress のサイトはもっと速く、もっと安全になります。すぐに PHP をバージョンアップしてください!'''
  
This page will explain why this matters to you, and then how you can fix it.
+
この記事では PHP をバージョンアップすべき理由とその方法について説明します。
  
== Why PHP Matters To You ==
+
== PHP のバージョンアップがなぜ必要なのか? ==
  
PHP is the coding language WordPress is built on, and its version is set at the server-level by your hosting company. Whilst you may be familiar with the importance of [https://wordpress.org/support/article/administration-screens/#updates keeping WordPress, and your themes and plugins up-to-date], keeping PHP up-to-date is just as important.
+
WordPress はプログラミング言語「PHP」で実装されています。この PHP のバージョン設定は、レンタルサーバー会社によりサーバー側で行われています。[https://wordpress.org/support/article/administration-screens/#updates WordPress 本体やテーマ、プラグインの最新バージョンを使用すること]の重要性は理解されていると思いますが、PHP の最新バージョンを使用することも同じように重要です。
  
There are two main benefits to keeping PHP up-to-date:
+
PHP の最新バージョンには大きく2つの利点があります。
  
* '''Your website will be faster''' as the latest version of PHP is more efficient. Updating to the latest supported version (currently 7.3) can deliver a huge performance increase; up to 3 or 4x faster for older versions.
+
* '''Web サイトがより速くなります。''' PHP の最新バージョンは以前のバージョンよりも効率的に動作します。最新のサポートバージョン(現在は7.3)にアップグレードすると、以前のバージョンに比べてパフォーマンスが最大で3倍〜4倍、向上します。
* '''Your website will be more secure.''' PHP, like WordPress, is maintained by its community. Because PHP is so popular, it is a target for hackers – but the latest version will have the latest security features. Older versions of PHP do not have this, so updating is essential to keep your WordPress site secure.
+
* '''Web サイトがより安全になります。''' PHP WordPress と同様にコミュニティによってメンテナンスされています。PHP は非常に人気があるため、ハッカーの標的です。最新のバージョンには最新のセキュリティ機能が実装されていますが、以前のバージョンにはこうした機能が含まれていません。PHP のアップデートは WordPress サイトの安全性にとって非常に重要です。
  
And then there are a number of secondary benefits:
+
さらに副次的な利点がいくつもあります。
  
* '''A faster WordPress website will be rewarded by search engines''', so you’ll rank higher in search!
+
* '''速い WordPress サイトは検索エンジンに高く評価されます。''' したがって検索ランクが上がります!
* '''A faster website will retain visitors better''' (they’ll leave if it takes too long to load), making your website more effective.
+
* '''速いサイトは訪問者の滞在時間が長くなります。''' 訪問者はロードに長い時間がかかれば離脱します。パフォーマンスが良ければサイトはその分、効率的になります。
* '''A more secure website is better protected against hackers''', and the cost and reputational damage associated with a hacked website.
+
* '''高いセキュリティを保つサイトはハッカーに対してより安全です。''' サイトがハッキングされれば対応コストがかかりますし、サイトの評判も下がります。
  
These benefits are good for you, and good for your website’s visitors. These are the reasons you should update PHP today. The next section will show you how to do this.
+
以上の利点はあなたにとってもサイトの訪問者にとっても有用です。今すぐ PHP を更新してください。次にその方法について説明します。
  
== Before you update your PHP version ==
 
  
This section starts off with some warnings, but don’t be afraid! As with most things technical, we just need to cover some background before we can get to the part where you update your PHP version.
+
== PHP をバージョンアップする前に ==
  
Updating your PHP version should not be a problem, but we can’t guarantee that it’s not. WordPress itself works with PHP versions as far back as 5.2.4 (we’re currently recommending version 7.3, so this is great backward compatibility!), but we don’t know if your themes or plugins will work. They should, and popular or reputable ones almost certainly will be, but we can’t guarantee it.
+
この節は警告から始まりますが安心してください。ほとんどが技術的な話しで、PHP のバージョンアップ前に必要ないくつかの背景情報を説明するだけです。
  
There are a couple of steps you should take to mitigate any risk before proceeding:
+
PHP のバージョンアップに特に問題はないはずですが、必ずないとは保証できません。WordPress 自体は PHP のはるか昔のバージョン 5.2.4 以降から動作しますが (現在の推奨バージョンは 7.3 ですから、ものすごい後方互換性です!)、使っているテーマやプラグインがどのバージョンで動作するかまでは分かりません。大部分は最新の PHP で動作しますし、人気があって信頼のおけるものはほぼ確実に動作しますが、保証はできません。
  
* '''Make a backup of your website''': a backup will let you revert your site to how it is right now in the event anything goes wrong. There are [https://wordpress.org/plugins/search/backup/ plenty of free backup plugins available], so if you don’t have a backup solution already – use one of these. In order to revert this backup, you’ll also need your web host to move your PHP version back to your current version (we’ll cover how to do this later).
+
バージョンアップ前に以下の手順に従い、リスクを減らしてください。
* '''Update WordPress, themes, and plugins''': from your WordPress Dashboard, head to Updates, and then update all. You should do this regularly anyway. 🙂 When done, check your site is working as expected.
+
* '''Check PHP compatibility''': install the [https://wordpress.org/plugins/php-compatibility-checker/ PHP Compatibility Checker plugin] to check your themes and plugins for possible issues. This plugin isn’t perfect and may miss items or flag false positives, but it does work in most cases.
+
* '''Fix any PHP compatibility issues''': if the PHP Compatibility Checker plugin picks up any issues, get in touch with the theme or plugin developer and ask them to investigate. If they can’t or won’t get back to you, have a look for themes or plugins on [https://wordpress.org/ WordPress.org] with similar functionality and use one of these instead.
+
  
Run through these steps, and you’ll be ready to update the PHP version on your WordPress site – and enjoy all of the benefits that come with this!
+
* '''Web サイトをバックアップしてください。''': バックアップがあれば何か起きた場合にサイトを現在の正常な時点に戻せます。[https://ja.wordpress.org/plugins/search/backup/ 多くの無料のバックアッププラグインを利用できますので]、もし現在、バックアップ手段を持っていなければ、どれか1つをインストールしてバックアップを取得してください。バックアップを戻すには、ホストの PHP のバージョンも現在のものに戻す必要があります。方法については後述します。
 +
* '''WordPress 本体、テーマ、プラグインをアップデートしてください。''': WordPress の管理画面の左サイドメニューから「更新」を選択し、すべてを更新してください。ちなみに更新は定期的に行いましょう 🙂  完了したら、サイトが正しく動作していることを確認してください。
 +
* '''PHP の互換性をチェックしてください。''': [https://ja.wordpress.org/plugins/php-compatibility-checker/ PHP Compatibility Checker プラグイン]をインストールし、テーマやプラグインの互換性をチェックしてください。このプラグインのチェックも完璧ではなく、項目やフラグを誤って判定する場合もありますが、ほとんどのケースで正しく動作します。
 +
* '''PHP 互換性の問題を修正してください。''': PHP Compatibility Checker プラグインが問題を報告する場合には、該当するテーマやプラグインの開発者に連絡し、調査を依頼してください。もし修正できない場合、または連絡がない場合には、[https://wordpress.org/ WordPress.org] 上で同じ機能を持つ代替のテーマやプラグインを検索し、インストールしてください。
  
If you run into any issues whilst doing this or need help, you should contact a professional web developer, your hosting company, or your theme and plugins authors. All of these will be happy to help here.
+
以上の手順を終えれば、WordPress サイトの PHP をバージョンアップできます。サイトのパフォーマンスを向上し、安全性を高めましょう!
  
We can now get on to the final part: actually updating your website’s PHP version.
+
手順の途中でエラーが発生したりヘルプが必要な場合は、周囲の Web 開発に詳しい人やレンタルサーバー会社、テーマやプラグインの作者に相談してください。きっと喜んで手助けしてくれるでしょう。
  
 +
最後のパートは、サイトの PHP のバージョンアップについてです。
  
== How to update your website’s PHP version for a faster, more secure website ==
+
== サイトの PHP をバージョンアップして、より速く、より安全にするには ==
  
You’re now ready to update your website’s PHP version! You’ve done due diligence, got backups, and are in the best possible shape to do the update.
+
サイトの PHP をバージョンアップする準備が整いました。ここまで細心の注意を払い、バックアップを取得し、可能な限りバージョンアップに最適な状態にあるはずです。
  
As the PHP version is set at the server level by your hosting company, updating involves either interacting with your host’s settings or asking them to do it.
+
PHP のバージョンはレンタルサーバー会社のサーバー側で設定されるためバージョンアップ作業も、サーバーの設定を変更するか、レンタルサーバー会社に依頼するかになります。
  
Thus, exactly how to do the update depends on your hosting company. We’ve asked hosting companies to submit instructions on how to update your PHP version on their hosting, and [https://github.com/WordPress/servehappy-resources/blob/master/tutorials/hosting-specific/tutorials-en.md you’ll find a list of hosts who have instructions available here].
+
したがってバージョンアップの実際の手順はレンタルサーバー会社によって異なります。各会社に協力いただきバージョンアップの方法について、[https://github.com/WordPress/servehappy-resources/blob/master/tutorials/hosting-specific/tutorials-ja.md こちらの文書(https://github.com/WordPress/servehappy-resources/blob/master/tutorials/hosting-specific/tutorials-ja.md)] にまとめました。
 
+
リストに会社名がない場合は、メールで問い合わせましょう。以下にメールの雛形を添付します。
If you can’t find your host on this list, then email your hosting company and ask them to help! Here’s some template text you can use:
+
  
 
<pre>
 
<pre>
Dear Hosting Provider,
+
レンタルサーバー会社 担当様
 
+
I want my website to be as performant and secure as
+
possible with the latest version of PHP. For the server
+
my WordPress site is hosted on, I want to ensure that
+
is the case. If I am not already on the latest version
+
of PHP, please let me know what steps I need to take
+
to update.
+
  
Thanks!
+
Web サイトのパフォーマンスを上げ、より安全にするため、最新の PHP にバージョンアップしたいと思います。
 +
WordPress が可動しているサーバーの PHP は最新バージョンでしょうか?
 +
もし最新でない場合には、どうすればバージョンアップできますか?
 
</pre>
 
</pre>
  
If you run into any issues at this stage, either change the PHP version back yourself, contact your hosting company or a professional web developer. In the unlikely event something goes wrong and you need to restore your backup, contact your host and ask them to restore the previous version of PHP you had running. You can then restore your backup.
+
この段階でうまく動作しない場合は PHP のバージョンを自分で戻すか、レンタルサーバー会社や Web 開発に詳しい人に相談してください。手順としてはまず使用していた PHP のバージョンを戻すようレンタルサーバー会社に相談してください。次に、取得していたバックアップで元に戻します。
  
You should now have all the information you need to update! Nice work! With an up-to-date version of PHP you’ll enjoy a faster, more secure website and happier visitors.
+
アップデートに必要な情報はすべてです。確認ありがとうございます。PHP の最新バージョンを使用して、より速い、より安全な Web サイトを楽しみ、訪問者を幸せにしましょう。
  
== Faster, more secure WordPress websites for all ==
+
== より速く、より安全な WordPress サイトを全員に ==
  
Making sure you have the latest version of PHP ensures your website is as fast, and secure as possible.
+
最新の PHP バージョンの使用は、Web サイトが可能な限り高速で安全であることを意味します。
  
You now have all the information you need to update to the latest version of PHP, and you know how to update in the future as well. Look out for more PHP update messages on your WordPress Dashboard going forwards, or keep an eye on your hosting company’s news for more information.
+
これまで PHP の最新バージョンにアップデートする方法について説明しましたが、将来のバージョンアップでも同様の方法で更新できます。WordPress の管理画面に表示される PHP アップデートのお知らせや、レンタルサーバー会社のニュースに注意してください。
  
As a final reminder: contact your hosting company, a professional web developer, or your theme and/or plugin authors for any additional questions. They’ll all be able to help out with their areas of expertise.
+
最後に。追加の質問があればレンタルサーバー会社や Web 開発者、テーマやプラグインの作者に相談してください。全員、専門分野についての助言を惜しまないはずです。
  
'''Thanks for making the internet a better place!'''
+
'''インターネットをより良い場所にするためのご協力に感謝します!'''
  
 
オリジナル文書: https://wordpress.org/support/update-php/
 
オリジナル文書: https://wordpress.org/support/update-php/

2019年2月15日 (金) 08:43時点における版

WordPress のサイトはもっと速く、もっと安全になります。すぐに PHP をバージョンアップしてください!

この記事では PHP をバージョンアップすべき理由とその方法について説明します。

PHP のバージョンアップがなぜ必要なのか?

WordPress はプログラミング言語「PHP」で実装されています。この PHP のバージョン設定は、レンタルサーバー会社によりサーバー側で行われています。WordPress 本体やテーマ、プラグインの最新バージョンを使用することの重要性は理解されていると思いますが、PHP の最新バージョンを使用することも同じように重要です。

PHP の最新バージョンには大きく2つの利点があります。

  • Web サイトがより速くなります。 PHP の最新バージョンは以前のバージョンよりも効率的に動作します。最新のサポートバージョン(現在は7.3)にアップグレードすると、以前のバージョンに比べてパフォーマンスが最大で3倍〜4倍、向上します。
  • Web サイトがより安全になります。 PHP は WordPress と同様にコミュニティによってメンテナンスされています。PHP は非常に人気があるため、ハッカーの標的です。最新のバージョンには最新のセキュリティ機能が実装されていますが、以前のバージョンにはこうした機能が含まれていません。PHP のアップデートは WordPress サイトの安全性にとって非常に重要です。

さらに副次的な利点がいくつもあります。

  • 速い WordPress サイトは検索エンジンに高く評価されます。 したがって検索ランクが上がります!
  • 速いサイトは訪問者の滞在時間が長くなります。 訪問者はロードに長い時間がかかれば離脱します。パフォーマンスが良ければサイトはその分、効率的になります。
  • 高いセキュリティを保つサイトはハッカーに対してより安全です。 サイトがハッキングされれば対応コストがかかりますし、サイトの評判も下がります。

以上の利点はあなたにとってもサイトの訪問者にとっても有用です。今すぐ PHP を更新してください。次にその方法について説明します。


PHP をバージョンアップする前に

この節は警告から始まりますが安心してください。ほとんどが技術的な話しで、PHP のバージョンアップ前に必要ないくつかの背景情報を説明するだけです。

PHP のバージョンアップに特に問題はないはずですが、必ずないとは保証できません。WordPress 自体は PHP のはるか昔のバージョン 5.2.4 以降から動作しますが (現在の推奨バージョンは 7.3 ですから、ものすごい後方互換性です!)、使っているテーマやプラグインがどのバージョンで動作するかまでは分かりません。大部分は最新の PHP で動作しますし、人気があって信頼のおけるものはほぼ確実に動作しますが、保証はできません。

バージョンアップ前に以下の手順に従い、リスクを減らしてください。

  • Web サイトをバックアップしてください。: バックアップがあれば何か起きた場合にサイトを現在の正常な時点に戻せます。多くの無料のバックアッププラグインを利用できますので、もし現在、バックアップ手段を持っていなければ、どれか1つをインストールしてバックアップを取得してください。バックアップを戻すには、ホストの PHP のバージョンも現在のものに戻す必要があります。方法については後述します。
  • WordPress 本体、テーマ、プラグインをアップデートしてください。: WordPress の管理画面の左サイドメニューから「更新」を選択し、すべてを更新してください。ちなみに更新は定期的に行いましょう 🙂 完了したら、サイトが正しく動作していることを確認してください。
  • PHP の互換性をチェックしてください。: PHP Compatibility Checker プラグインをインストールし、テーマやプラグインの互換性をチェックしてください。このプラグインのチェックも完璧ではなく、項目やフラグを誤って判定する場合もありますが、ほとんどのケースで正しく動作します。
  • PHP 互換性の問題を修正してください。: PHP Compatibility Checker プラグインが問題を報告する場合には、該当するテーマやプラグインの開発者に連絡し、調査を依頼してください。もし修正できない場合、または連絡がない場合には、WordPress.org 上で同じ機能を持つ代替のテーマやプラグインを検索し、インストールしてください。

以上の手順を終えれば、WordPress サイトの PHP をバージョンアップできます。サイトのパフォーマンスを向上し、安全性を高めましょう!

手順の途中でエラーが発生したりヘルプが必要な場合は、周囲の Web 開発に詳しい人やレンタルサーバー会社、テーマやプラグインの作者に相談してください。きっと喜んで手助けしてくれるでしょう。

最後のパートは、サイトの PHP のバージョンアップについてです。

サイトの PHP をバージョンアップして、より速く、より安全にするには

サイトの PHP をバージョンアップする準備が整いました。ここまで細心の注意を払い、バックアップを取得し、可能な限りバージョンアップに最適な状態にあるはずです。

PHP のバージョンはレンタルサーバー会社のサーバー側で設定されるためバージョンアップ作業も、サーバーの設定を変更するか、レンタルサーバー会社に依頼するかになります。

したがってバージョンアップの実際の手順はレンタルサーバー会社によって異なります。各会社に協力いただきバージョンアップの方法について、こちらの文書(https://github.com/WordPress/servehappy-resources/blob/master/tutorials/hosting-specific/tutorials-ja.md) にまとめました。 リストに会社名がない場合は、メールで問い合わせましょう。以下にメールの雛形を添付します。

レンタルサーバー会社 担当様

Web サイトのパフォーマンスを上げ、より安全にするため、最新の PHP にバージョンアップしたいと思います。
WordPress が可動しているサーバーの PHP は最新バージョンでしょうか?
もし最新でない場合には、どうすればバージョンアップできますか?

この段階でうまく動作しない場合は PHP のバージョンを自分で戻すか、レンタルサーバー会社や Web 開発に詳しい人に相談してください。手順としてはまず使用していた PHP のバージョンを戻すようレンタルサーバー会社に相談してください。次に、取得していたバックアップで元に戻します。

アップデートに必要な情報はすべてです。確認ありがとうございます。PHP の最新バージョンを使用して、より速い、より安全な Web サイトを楽しみ、訪問者を幸せにしましょう。

より速く、より安全な WordPress サイトを全員に

最新の PHP バージョンの使用は、Web サイトが可能な限り高速で安全であることを意味します。

これまで PHP の最新バージョンにアップデートする方法について説明しましたが、将来のバージョンアップでも同様の方法で更新できます。WordPress の管理画面に表示される PHP アップデートのお知らせや、レンタルサーバー会社のニュースに注意してください。

最後に。追加の質問があればレンタルサーバー会社や Web 開発者、テーマやプラグインの作者に相談してください。全員、専門分野についての助言を惜しまないはずです。

インターネットをより良い場所にするためのご協力に感謝します!

オリジナル文書: https://wordpress.org/support/update-php/