当サイト、Codex 日本語版は今後積極的な更新は行わない予定です。後継となる新ユーザーマニュアルは、https://ja.wordpress.org/support/ にあります。
万が一、当サイトで重大な問題を発見した際などは、フォーラムWordSlack #docs チャンネルでお知らせください。</p>

「FAQ/インストール」の版間の差分

提供: WordPress Codex 日本語版
< FAQ
移動先: 案内検索
(表記ゆれ)
(移動メッセージで置き換え。)
 
1行目: 1行目:
[[#Installation|コンテンツ開始部分へスキップ↓]]
+
このページは https://ja.wordpress.org/support/article/faq-installation/ へ移動しました。
 
+
__TOC__
+
 
+
<div style="clear:both; height:20px"></div><!-- do not remove -->
+
 
+
<div id="Installation">
+
== インストール ==
+
</div>
+
<div id="How_do_I_install_WordPress.3F">
+
=== WordPress のインストール方法は? ===
+
</div>
+
参照: [[WordPress のインストール]]
+
 
+
<div id="What_is_the_Famous_5-Minute_Install.3F">
+
=== 「5分間インストール」とは何ですか? ===
+
</div>
+
参照: [[WordPress のインストール#Famous_5-Minute_Install|WordPress 5分間インストール]]
+
 
+
<div id="How_do_I_find_a_good_host_for_my_WordPress_blog.3F">
+
===WordPress ブログに適したホストを探したいのですが。 ===
+
</div>
+
参照: [[サーバの用意|サーバーの用意]]、[[レンタルサーバ情報|レンタルサーバー情報]]
+
 
+
<div id="How_do_I_install_using_CPanel_.2F_CPanel_X.3F">
+
=== CPanel / CPanel X を使ってインストールするには? ===
+
</div>
+
参照: [[Using cPanel|cPanel]]/[[:en:Using cPanel|en]]
+
 
+
<div id="How_do_I_configure_the_.27wp-config.27_file.3F">
+
=== 'wp-config' ファイルの設定方法は? ===
+
</div>
+
参照: [[wp-config.php の編集]]
+
 
+
<div id="What_are_the_requirements_for_installing_WordPress.3F">
+
=== WordPress の設置条件は? ===
+
</div>
+
参照: [[サーバの用意|サーバーの用意]]、[http://wordpress.org/about/requirements/ Requirements at WordPress.org](英語)
+
 
+
<div id="How_do_I_get_WordPress_to_use_my_language.3F">
+
=== 私の言語で使える WordPress はありますか? ===
+
</div>
+
参照: [[WordPress を他の言語で使う]]、[[:en:WordPress_Localization|WordPress Localization]](英語、最新情報)
+
 
+
<div id="Do_I_need_to_create_a_database.3F">
+
=== データベースの作成は必要ですか? ===
+
</div>
+
 
+
WordPress は、データを格納する [[用語集#MySQL|MySQL データベース]]へのアクセスを必要とします。そのため、データベースが必須です。
+
 
+
次の場合、WordPress のインストールの前に、新規データベースを作成します。
+
# サーバー上にまだデータベースを作成していないとき
+
# 気前のよいホストが複数のデータベースを提供してくれていて、今回設置したいブログに別のデータベースを使いたいとき
+
 
+
WordPress のインストール毎に新規データベースを作成する必要はありません。
+
 
+
* 一つのデータベースを使って複数の WordPress をインストールしたい場合、WordPress 毎に異なるデータベース接頭辞(テーブル名に付ける prefix)を付けるよう、<code>[[wp-config.php の編集# $table_prefix|wp-config.php]]</code> ファイルの編集に注意します。
+
* 新規ブログ用に新規データベースを設置したい場合、<code>[[wp-config.php の編集|wp-config.php]]</code> で正しいデータベース名等を設定するよう気をつけてください。
+
 
+
参照: [[WordPress のインストール#Detailed_Instructions|インストール手順詳細]]
+
 
+
<div id="What_is_the_403_error_I_get_when_trying_to_see_my_site.3F">
+
=== サイトを表示しようとすると 403 エラーが出ます ===
+
</div>
+
'''症状:''' 正しいユーザー名とパスワードを入れてもログインできず、以下のようなエラーメッセージが表示される。
+
 
+
<pre> You are not authorized to view this page
+
You might not have permission to view this
+
directory or page using the credentials you
+
supplied. If you believe you should be able
+
to view this directory or page, please try
+
to contact the Web site by using any e-mail
+
address or phone number that may be listed
+
on the personal.fredsmith.com home page.
+
You can click Search to look for information
+
on the Internet. HTTP Error 403 - Forbidden''</pre>
+
 
+
'''解決策:''' ホストが Windows サーバーの場合は Directory Index の問題かもしれません。サーバーのデフォルト設定では <tt>index.htm</tt>、<tt>index.html</tt>、<tt>default.htm</tt>、<tt>default.html</tt> または <tt>default.asp</tt> ファイルを読み込むようになっています。
+
 
+
WordPress は PHP で動いていますので、デフォルトページは <tt>index.php</tt> です。このファイルをデフォルト設定に加えるには、コントロールパネルの '''Web Options''' に行って、'''Directory Indexes''' セクションに <tt>index.php</tt> を追加してください。
+
 
+
この件に関しては、必要であればホスティングサービスに連絡してください。
+
 
+
<div id="Can_I_rename_the_WordPress_folder.3F">
+
=== WordPress のフォルダ名を変えられますか? ===
+
</div>
+
WordPress のインストールがこれからであれば、WordPress ファイルのアップロード前/後どちらでも、WordPress フォルダをリネームできます。
+
 
+
インストール済み WordPress のフォルダ名をリネームしたい場合は、管理者として WordPress にログインし、[[管理パネル#Settings - Configuration Settings|設定]] > [[管理パネル/一般設定|一般設定]] 画面で次の項目を変更してください。
+
 
+
* WordPress のアドレス (URL)
+
* ブログのアドレス (URL)
+
 
+
この変更の後、WordPress ファイルを置いているディレクトリ(フォルダ)名をリネームできます。
+
 
+
参照: [[Moving WordPress|WordPress の移動]]
+
 
+
<div id="How_can_I_reset_my_password.3F">
+
=== パスワードをリセットするには? ===
+
</div>
+
参照: [[Resetting Your Password|パスワードのリセット方法]]<!-- http://www.tamba2.org.uk/wordpress/phpmyadmin -->
+
 
+
<div id="Why_is_my_upload_directory_.22C:apachehtdocswordpress.22.3F">
+
=== アップロードディレクトリが "C:apachehtdocswordpress" となるのはなぜですか?===
+
</div>
+
アップロードパスを入力する際に「バックスラッシュ」を使っていませんか?ディレクトリのパスの指定には通常のスラッシュ(<code>/</code>)をお使いください。
+
 
+
<div id="Can_I_install_WordPress_on_Windows_2000.3F">
+
=== Windows 2000 に WordPress をインストールできますか? ===
+
</div>
+
Windows プラットフォームに WordPress をインストールしようとしているなら、[[用語集#MySQL|MySQL データベース]]バージョン '''4.1.7 は使わない'''でください。<!-- 次の説明(フォーラムへの投稿)をお読みください。
+
<blockquote>
+
"To all those having problems installing  WordPress on your own Windows 2000 (and other Win OS versions) workstation - and maybe some host servers, too: Do not use MySQL 4.1.7 - it is the problem if you get "Error establishing a database connection!". It does not seem compatible with the other components. Use MYSQL 4.0.22 instead.<br /><br />
+
Thanks to the Reply by ADAMANT in response to the POST of Nov 6, 2004 02:21:29 by ANTOINE, the  WordPress installation really did become only 5 minutes, after two days of frustration:
+
<br /><br />
+
I started with Windows 2000, PHP 4.3.9, Apache 1.3.33 and MySQL 4.1.7. I spent two days checking my wp-config.php literally 100 times; making changes; troubleshooting my database, using every known name for my host (localhost, 127.0.0.1, <IP address>, computer name, etc...) to no avail. I kept getting:<br /><br />
+
"Error establishing a database connection!" ...
+
<br /><br />
+
I knew it wasn't my config. So thanks to ADAMANT's suggestion, I uninstalled MySQL 4.1.7 and downloaded and installed MySQL 4.0.22 from mysql.org. After installing and configuring the new (old) MySQL, which took approximately 7 minutes (very easy), I ran the install.php once again and YES!! it actually took less than 5 minutes for the  WordPress install.<br /><br />
+
NOTE: the Apache web site says NOT to use Apache 2 in production. So, after all my wasted time with the latest MySQL, I suggest the following to those who can control their environment:<br /><br />
+
PHP 4.3.9, Apache 1.3.33 and MySQL 4.0.22. On Windows at least, they all work well together."
+
<br /><br />Steven</blockquote> -->
+
 
+
'''追記''': MySQL 4.1.7 は今までの方法と互換性がないパスワード暗号化方法を使っています。もし MySQL 4.1.7 で WordPress を動かしたい場合は、ユーザーパスワードを旧形式で設定しておく必要があります (mysqladmin を使っている場合、password ではなく password-old)。 -- Nabil
+
 
+
MySQL コマンドラインインターフェースからテーブルを編集するには以下のコマンドを使います。
+
 
+
USE mysql;
+
SET PASSWORD FOR 'wordpressuser'@'localhost' = OLD_PASSWORD('somePassword444');
+
FLUSH PRIVILEGES;
+
 
+
通常のパスワード設定方法では、新形式のパスワード機能が使われてしまいます。もうひとつの方法は、MySQL サービスを --old-passwords オプションで実行することです。ただ、上記のコマンドで XP 上のバージョン4.1.19および4.1.20を使ったインストールに成功しています。-- Grey
+
 
+
'''注意:''' 上記はユーザーによるコメントであり、環境に依存する場合があります。
+
 
+
<div id="Advanced_Installation">
+
== インストール 応用編==
+
</div>
+
 
+
<div id="How_do_I_install_WordPress_with_the_files_in_different_directories.3F">
+
=== ファイルを置いたディレクトリとは異なる位置に WordPress をインストールするには? ===
+
</div>
+
次の質問にもお答えします。
+
 
+
* あるフォルダにブログを置きながら、index をルートにするには?
+
* 全てのファイルを <nowiki>www.example.com/wordpress</nowiki> に置いたまま、訪問者には www.example.com にあるブログを見せるには?
+
* index.php があるディレクトリとは別のディレクトリに WordPress をインストールするには?
+
 
+
参照: [[Giving WordPress Its Own Directory|サブディレクトリへの設置]]、[[Moving WordPress|WordPress の移動]]
+
 
+
<div id="How_can_I_hide_my_blog_from_people.3F">
+
=== ブログを誰にも見られないようにできますか? ===
+
</div>
+
テストブログや新ブログを立ち上げたり、何か他の理由でアクセスを制限したい場合は以下の方法に従ってください。
+
 
+
; '''Apache'''
+
: '''.htaccess''' ファイル(パーマリンク設定コードが含まれているファイル)で特定の IP アドレスをチェックしてサイトの閲覧を防ぐことはできますが、確実とはいえません。これは IP アドレスをブロックするだけで特定の人に向けたものではないので、他の IP アドレスからならアクセスできてしまいます。
+
:* [http://mikeneko.creator.club.ne.jp/~lab/web/htaccess/access.html#access1 ミケネコの htaccess リファレンス > 特定のホストのアクセスを制限する]
+
: '''.htaccess''' を使えば、他の人がサイト内の画像に「直リンク」(帯域幅の盗用)するのを防いだり、ブログ全体にパスワードをかけたりすることもできます。
+
 
+
; '''Apache ベーシック認証'''
+
: サイトへのアクセスを制限するために '''.htaccess''' と '''.htpasswd''' を使うには以下をご覧ください。
+
:* [http://mikeneko.creator.club.ne.jp/~lab/web/htaccess/auth.html#auth1 パスワードによるユーザー認証のかけ方](ミケネコの htaccess リファレンス)
+
:* [http://www.japansecurity.net/htpasswd/1.htm .htaccess による認証用 パスワード暗号化ツール]
+
: ''注:'' サイトにアクセスする際、パスワードは Base64 でエンコードされます。暗号化は強くないため、解読されやすいといえます。
+
 
+
; '''Windows IIS ベーシック認証'''
+
: IIS サーバーでパスワードによるアクセス制限をするには、Allow Anonymous Access を非選択にし、Basic Authentication を選択します。ユーザー名とパスワードが必要になります。
+
: ''注:'' サイトにアクセスする際、パスワードは Base64 でエンコードされます。暗号化は強くないため、解読されやすいといえます。
+
: 参照:
+
:* [http://support.microsoft.com/default.aspx?scid=kb;ja-jp;310344 Microsoft サポート - IIS 5.0 Web サイト認証機能の設定]
+
:* [http://support.microsoft.com/kb/299970/JA-JP/ Microsoft サポート - NTFS セキュリティを使用して IIS 4.0 または 5.0 上の Web ページを保護する方法]
+
:* [http://support.microsoft.com/default.aspx?scid=kb;ja-jp;308160  Microsoft サポート - Windows 2000 でインターネット インフォメーション サービスの Web 認証を構成する方法]
+
;'''検索エンジンのスパイダーやボット'''
+
: 検索エンジンはサイトをインデックス化し、コンテンツをキャッシュします。これを防ぐには、[[管理パネル/プライバシー設定|管理パネルのプライバシー設定]]を変更すると良いでしょう。また、'''robots.txt''' ファイルを使うこともできます。
+
:* [http://www.google.com/support/webmasters/bin/answer.py?hl=jp&answer=156449 robots.txt ファイルを使用してページをブロックまたは削除する](Google ウェブマスターセントラル)
+
 
+
<div id="How_can_I_solve_login_problems.3F">
+
=== ログイン問題を解決するには? ===
+
</div>
+
参照: [[Login Trouble|ログイントラブル]]<!-- [http://faq.wordpress.net/view.php?p=68 How I solve login problems after installation with version 1.2 ?] -->
+
 
+
===リバースプロキシを使用している場合には WordPress をどうやって使えばよいですか?===
+
 
+
一部の設定では HTTP_HOST ヘッダー以外で URL を生成する必要があります。リバースプロキシは元のリクエストを取得し、複数のサーバーへ送信します。これを行うために、内部サーバードメインで HTTP_HOST を上書きします。このドメインへの公開アクセスができない場合、画像が表示されなかったりリダイレクトループにはまってしまったりという現象が発生します。この問題を修正するには、どのヘッダー情報が正しいドメイン名を含んでいるかを割り出して、そのホスト名が HTTP_HOST を上書きするよう <code>wp-config.php</code> に一行追加する必要があります。
+
 
+
<code>SERVER_NAME</code> を使う必要がある場合は <code>wp-config.php</code> に以下の行を追加してください。
+
 
+
<pre>$_SERVER['HTTP_HOST'] = $_SERVER['SERVER_NAME'];</pre>
+
 
+
<code>HTTP_X_FORWARDED_HOST</code> を使う必要がある場合は以下の行を追加してください。
+
 
+
<pre>$_SERVER['HTTP_HOST'] = $_SERVER['HTTP_X_FORWARDED_HOST'];</pre>
+
 
+
参照: この件に関する[http://old.nabble.com/When-HTTP_HOST-does-not-point-to-the-blog-td18097138.html メーリングリストスレッド]もご覧ください。
+
 
+
<div id="FTP">
+
== FTP ==
+
</div>
+
 
+
<div id="How_do_I_FTP.3F">
+
=== FTP とはどうやるのですか? ===
+
</div>
+
参照: [[Using FileZilla|FileZilla の使い方]]/[[:en:Using FileZilla|en]]、[[FTP クライアント]]
+
 
+
<!-- <div id="How_do_I_use_Filezilla.3F">
+
=== Filezilla の使い方は? ===
+
</div>
+
参照: [[Using FileZilla]]/[[:en:Using FileZilla|en]]
+
-->
+
<div id="How_do_I_upload_the_files_and_folders.3F">
+
=== ファイルやフォルダをアップロードするには? ===
+
</div>
+
参照: [[Uploading WordPress to a remote host|リモートホストへの WordPress のアップロード方法]]/[[:en:Uploading WordPress to a remote host|en]]
+
 
+
<div id="How_do_I_CHMOD_files.3F">
+
===ファイルの CHMOD はどうやるの?===
+
</div>
+
参照: [[ファイルパーミッションの変更]]
+
 
+
<div id="MySQL">
+
==MySQL==
+
</div>
+
<div id="Do_I_really_need_MySQL.3F">
+
=== MySQL は本当に必要? ===
+
</div>
+
WordPress ブログを稼動させるには確かに [[用語集#MySQL|MySQL]] データベースサーバが必要です。[[用語集#MySQL|MySQL]] データベースサーバにのみ対応しています。[[サーバ要件|PHP および MySQL の要件]]をご確認ください。
+
 
+
<div id="Can_I_use_a_database_other_than_MySQL.3F">
+
=== MySQL 以外のデータベースは使えますか? ===
+
</div>
+
現在のところ、他のデータベースには正式対応していません。
+
+
他にも将来 WordPress が対応することに興味を持っている PostgreSQL や SQLite のような優れたデータベース保存エンジンがあります。複数のデータベースに対応するのは想像以上に大変なため、現在活発な開発は行っていませんしかし、最適なアプローチについての設計上の議論はたくさん行われています。対応データベースを増やすアプローチについての話し合いは、[[代替データベースの使い方]]ページでどうぞ。
+
 
+
また、プラグインとして [http://wordpress.org/extend/plugins/postgresql-for-wordpress/ PostgreSQL for WordPress (PG4WP)]、[http://wordpress.org/extend/plugins/external-database-authentication/ External DB authentication]、[http://wordpress.org/extend/plugins/pdo-for-wordpress/ PDO (SQLite) For Wordpress] などの試みがある。
+
 
+
<div id="Why_does_WordPress_use_MySQL.3F">
+
 
+
=== WordPress ではどうして MySQL を使うのですか? ===
+
</div>
+
[[用語集#MySQL|MySQL]] は速度の面で非常に優れています。また、世界のサーバーで広く使われているデータベースでもあります。オープンソースであり無料である [[用語集#MySQL|MySQL]] は、数多くの低価格 [[用語集#Linux|Linux]](と、Windows)ホストで利用できます。これはつまり WordPress(またはその他のデータベースを使った)サイトを運営し始めたい人にとっての壁がとても低いことを意味しています。また、[http://dev.mysql.com/doc/refman/4.1/ja/index.html MySQL のドキュメンテーション]([http://dev.mysql.com/doc/refman/5.1/ja/index.html 5.1])は実用的で、 効果的かつ綿密です(まったくの初心者の方には少し手強いかもしれませんが)。さらに、[[用語集#MySQL|MySQL]] を [[phpMyAdmin]] を使って直接操作できることも理由に加えると、MySQL がベストな選択だということは明白だと思います。WordPress はベストなものを常に求めているので、当然です!
+
 
+
<div id="PHP">
+
== PHP ==
+
</div>
+
<div id="What_is_phpMyAdmin.3F">
+
=== phpMyAdmin とは何ですか? ===
+
</div>
+
phpMyAdmin とは、web 上で MySQL 管理を操作することを目的として PHP 言語で書かれたツールです。
+
 
+
参照: [[用語集#phpMyAdmin|用語集 - phpMyAdmin]]、[[phpMyAdmin]]
+
 
+
<div id="Do_I_need_to_know_PHP_to_use_WordPress_.3F">
+
=== WordPress を使うために PHP について知っておくべきですか?===
+
</div>
+
いいえ。[[用語集#PHP|PHP]] を使って WordPress を編集することがあるのは、一部の[[プラグイン]]との統合を行う時くらいでしょう。そのほとんどの場合、やりかたはプラグイン付属のテキストファイルに分かりやすく書いてあるはずです。それ以外には PHP ファイルをまったく触らなくても WordPress を使うことができます。
+
 
+
<div id="Will_ WordPress_run_in_PHP_Safe_Mode.3F">
+
=== Safe Mode(セーフモード)の PHP で WordPress は動きますか? ===
+
</div>
+
もちろんです。ただし、もし問題が発生したときは[[セーフモードによる制限と対処方法]]をご覧ください。
+
 
+
<div id="Do_I_really_need_PHP.3F">
+
=== PHP は本当に必要? ===
+
</div>
+
WordPress を動かすには、[[用語集#PHP|PHP]](対応バージョンは[[サーバ要件]]ページで確認)が必ず必要です。PHP は WordPress のすべてのエンジンとなるスクリプト言語ですので、PHP がないサーバーはブログを形成するページを理解することはできません。
+
 
+
<div id="How_do_I_find_out_which_version_of_PHP_I_have.3F">
+
=== 使っている PHP のバージョンを確認するには? ===
+
</div>
+
使用中のサーバについての情報を得るには、<code>[http://jp.php.net/manual/ja/function.phpinfo.php phpinfo()]</code> 関数が使えます。これにより [[用語集#Apache|Apache]] および [[用語集#PHP|PHP]] のバージョン、[[用語集#mod_rewrite| mod_rewrite]] についての情報も分かります。
+
 
+
参照: [[Finding Server Info|サーバー情報の確認方法]]
+
 
+
<div id="Importing">
+
== インポート(コンテンツの取り込み) ==
+
</div>
+
<div id="How_can_I_import_posts_from_my_current_weblog_which_uses_a_different_blogging_tool.3F">
+
=== 別のブログツールでやっているブログから、記事をインポートできますか?===
+
</div>
+
参照: [[Importing Content|コンテンツのインポート]]
+
<!-- b2 情報はもういらないのでは -->
+
<!-- <div id="How_do_I_import_from_b2.3F">
+
=== b2 からインポートするには? ===
+
</div>
+
参照: [[Importing Content#b2|b2 からのインポート]] /[[:en:Importing Content#b2|en]] -->
+
 
+
<div id="How_do_I_import_from_Movable_Type_MT.3F">
+
=== Movable Type(MT)からインポートするには? ===
+
</div>
+
参照: [[Importing from Movable Type to WordPress|Movable Type から WordPress へのインポート]]
+
 
+
<div id="How_do_I_import_from_Blogger.3F">
+
=== Blogger からインポートするには? ===
+
</div>
+
参照: [[Importing Content#Blogger|Blogger からのインポート]]
+
 
+
<!-- <div id="How_do_I_import_from_Text_Pattern.3F">
+
=== Textpattern からインポートするには? ===
+
</div>
+
参照: [[Importing Content#Textpattern|Textpattern からのインポート]] -->
+
 
+
<div id="How_do_I_import_from_a_generic_RSS_Feed.3F">
+
=== 一般的な RSS フィードからインポートするには? ===
+
</div>
+
参照: [[Importing Content#Importing from an RSS feed|RSS フィードからのインポート]]
+
 
+
<div id="How_do_I_import_from_other_blogging_software.3F">
+
=== その他のブログソフトウェアからインポートするには? ===
+
</div>
+
参照: [[Importing Content|コンテンツのインポート]]
+
 
+
<div id="Upgrading">
+
== アップグレード ==
+
</div>
+
 
+
<div id="What_version_of_WordPress_do_I_have.3F">
+
=== 使っている WordPress のバージョンを確認するには? ===
+
</div>
+
 
+
現在使っている WordPress のバージョンを調べる方法はいくつかあります。
+
 
+
* 設置した WordPress の <code>wp-includes</code> ディレクトリにある <code>version.php</code> ファイルを [[用語集#Text editor|テキストエディタ]]で開いてください。設置したバージョン番号が書かれています。
+
* WordPress [[管理パネル]]では、どの画面でも一番下にバージョン番号が表示されます。
+
* テーマの中にはフッタ・テンプレートにバージョン番号を表示するものがあります。または、次のように自分で書き加えることもできます。
+
 
+
<pre><?php bloginfo('version'); ?></pre>
+
 
+
<div id="What_should_I_do_when_I_want_to_upgrade_WordPress_to_the_latest_version.3F">
+
=== WordPress を最新版にするにはどうしたらいいですか? ===
+
</div>
+
 
+
参照: [[WordPress のアップグレード]]
+
 
+
<div id="How_do_I_back_up_my_database.3F">
+
=== データベースのバックアップを取得するには? ===
+
</div>
+
参照: [[データベースのバックアップ]]
+
 
+
<div id="How_do_I_restore_my_database.3F">
+
=== データベースをリストア(復元)するには? ===
+
</div>
+
参照: [[データベースの復元]]
+
 
+
<div id="After_running_upgrade.php_get_the_message_.22It_doesn.27t_look_like_you.27ve_installed_WP_yet._Try_running_install.php..22">
+
=== upgrade.php 実行後、"これを実行する権限はありません。" というメッセージが出ます ===<!-- "It doesn't look like you've installed WP yet. Try running install.php." はもうなくなった模様-->
+
</div>
+
[[WordPress のアップグレード]]を実行後、"これを実行する権限はありません。"  と表示されます。この問題は、[[Roles and Capabilities#Administrator|管理者権限]]を持つユーザが存在しないことによるものかもしれません。
+
 
+
修正するには、[[phpMyAdmin]] から直接データベースを編集し、ユーザーに権限を与えます。ここでは[[wp-config.php_の編集#.24table_prefix_:_.E3.83.87.E3.83.BC.E3.82.BF.E3.83.99.E3.83.BC.E3.82.B9.E3.83.BB.E3.83.86.E3.83.BC.E3.83.96.E3.83.AB.E5.90.8D.E3.81.AE.E6.8E.A5.E9.A0.AD.E8.BE.9E|テーブル接頭辞]]がデフォルトのままの <code>wp_</code> であると仮定します。
+
 
+
注: データベースを触る場合には十分注意してください。データを失ったり壊してしまったりした場合、[[データベースのバックアップ|バックアップ]]を取っていない限りは元に戻すことはできません。
+
 
+
# [[データベース概要#Table: wp_user|wp_user テーブル]] を開き、管理者にしたいユーザーの ID を探します。
+
# [[データベース概要#Table: wp_usermeta|wp_usermeta テーブル]] で、<code>user_id</code> がその ID で、<code>meta_key</code> が <code>wp_capabilities</code> という行を探します。<code>meta_value</code> を <code>a:1:{s:13:"administrator";b:1;}</code> に変更します。
+
# 同じテーブルで <code>user_id</code> がステップ1で見つけた ID で、<code>meta_key</code> が <code>wp_user_level</code> という行を探します。<code>meta_value</code> を '''10''' に変更します。
+
 
+
参照: [http://wordpress.org/support/topic/62694?replies=20 WordPress サポートフォーラムの関連スレッド、2006年3月](英語)
+
 
+
<div id="How_do_you_force_a_database_upgrade.3F">
+
 
+
=== データベースのアップグレードを強制的に行なうには? ===
+
</div>
+
 
+
場合によっては、データベースのアップグレード処理を再実行する必要があるかもしれません。それには、[[データベース概要#テーブル: wp_options|<code>wp_options</code> テーブル]]の '''db_version''' の値をアップグレード'''前'''のバージョンの値に下げる必要があります。例えば、2.0.11 から 2.3 へデータベースを強制的にアップグレードしたいときは、'''db_version''' を '''3441''' に変更します。2.5 から 2.8 にアップグレードさせるには '''7558''' に変更します。
+
 
+
各 WordPress リリースの '''db_version'''(データベースバージョン番号)については、[[WordPress_Versions|WordPress バージョンページ]]を参照してください。
+
<!-- 重複リストがここにあったが、更新が遅れていくので削除。バージョン情報ページの最新情報へ誘導。 -->
+
 
+
値の変更には [[phpMyAdmin]] または ''wp-admin/options.php'' をお使いください。
+
 
+
'''注意''': 変更前に必ず[[データベースのバックアップ]]を取得してください。また、値を間違えないようご注意ください。<code>db_version</code> は、アップグレードスクリプトがデータベースの書き換え内容を判断するための重要な値です。
+
 
+
'''db_version''' を変更すると、ブログにログインするときに、データベースのアップグレードを促すリンクが表示されます。
+
 
+
<div id="Do_I_need_to_deactivate_plugins_before_using_the_core_update_option.3F">
+
 
+
=== 自動コアアップグレードを実行する前に、プラグインを無効化する必要はありますか? ===
+
</div>
+
従来のアップグレード手順では全てのプラグインを無効化する必要がありましたが、[[Version 2.7|WordPress 2.7]] 以降に含まれている[[Tools Upgrade SubPanel|コアアップグレード処理]]では、その必要はありません。以下は Ryan Boren による説明です。
+
 
+
「アップグレード処理の間、ブログはメンテナンスモードとなり、wp-settings.php の先頭で読み込みを停止します。プラグインも含め、何も実行されません。実行が許されるのは、プラグインが読み込まれないようにするための DB アップグレードのみです。問題が発生するかもしれず、その原因を見極めるためにアップグレード後にプラグインを一つずつ有効化していきたいのでなければ、プラグインを無効化する必要はありません。」
+
 
+
<div id="The_core_upgrade_is_not_working.2C_what_can_I_do.3F">
+
===コアアップグレードが動作しません。どうすればよいですか?===
+
</div>
+
<!--
+
If the core upgrade, for example upgrading from 2.7 to 2.7.1, is not working, one of these solutions might help:
+
# If the upgrade seems in an endless loop and you are using Memcache object cache backend, upgrade Memcache (see [http://trac.wordpress.org/ticket/8407 Trac Ticket 8407]).
+
# If upgrading fails due to a restrictive suexec (e.g. some Italian hosts) then try the [[wp-config.php の編集#Override_of_default_file_permissions|FS_CHMOD_DIR and FS_CHMOD_FILE in wp-config.php]] see [http://trac.wordpress.org/ticket/8478 Trac Ticket 8478]).
+
-->
+
例えば 2.7 から 2.7.1 へのアップグレードでコアアップグレード機能が動かない場合、次の解決策が役立つかもしれません。
+
# アップグレードが無限ループしている様子であり、バックエンドで Memcache object cache を使っている場合、Memcache をアップグレードしてください([http://trac.wordpress.org/ticket/8407 Trac Ticket 8407] 参照)。
+
# suexec の制限が原因でアップグレードが上手くいかない場合、[[wp-config.php の編集#Override_of_default_file_permissions|wp-config.php で FS_CHMOD_DIR と FS_CHMOD_FILE]] の設定を試してください([http://trac.wordpress.org/ticket/8478 Trac チケット 8478] 参照)。
+
 
+
== 旧バージョンに戻すには? ==
+
 
+
アップグレード前に取得しておいた[[WordPress のバックアップ|バックアップファイル]]を使って、'''WordPressファイルと[[データベース概要|データベース]]の両方'''を旧バージョンのものに戻します。
+
 
+
'''手順:'''
+
# WordPress ファイルを旧バージョンに戻す。(注)
+
## サーバー上の WordPress ディレクトリを別の名前に変更する(不安がないならサーバーから削除してもよい)。
+
## バックアップしてあった WordPress ファイル一式をサーバーへアップロードする。
+
# [[データベースの復元|データベースを旧バージョンに戻す]]。
+
# 正しく旧バージョンにできたか確認する。
+
#* [[#使っている WordPress のバージョンを確認するには?|WordPress 本体のバージョンを確認]]
+
#* [[phpMyAdmin]] 等を使って、[[データベース概要#テーブル: wp_options|<code>options</code> テーブル]]の '''db_version''' の値が合っているか確認する。<br />[[WordPress Versions|WordPress バージョン一覧]]に対応表がある(例えば WordPress 2.7.1 に戻したのであれば、db_version は '''9872''')。
+
# 表示や動作に問題がないか確認する。
+
 
+
(注)
+
* 上記1は'''上書きではいけません'''。新バージョンで追加されたファイルが消されずに残り、不具合の要因となります。上書きが不十分だった事例もあります。
+
* 万が一バックアップがない場合は、古いバージョンを[http://ja.wordpress.org/releases/ ダウンロード]できます。
+
* WordPress のスクリプトとデータベースは連携して動いています。バージョンが揃っていないと、使っているうちに不具合が生じたり、次回のアップグレードが正常に行なわれない可能性があります。
+
 
+
<!-- db_version が同じだったら DB リストアを省略できることも書いたほうがいい? -->
+
<!-- 新バージョンで投稿やコメントをしてから戻す場合のことも触れたほうがいい? -->
+
 
+
[[FAQ|FAQ に戻る]]
+
 
+
{{原文|FAQ Installation|135437}}<!-- 2013-09-11T20:21:23 MichaelH 版 -->
+
 
+
{{DEFAULTSORT:FAQいんすとおる}}
+
[[Category:初心者向けトピック]]
+
[[Category:設置]]
+
[[Category:アップグレード]]
+
[[Category:トラブルシューティング]]
+
[[Category:WordPress ヘルプ]]
+
[[Category:wp2.7]]
+
 
+
[[en:FAQ Installation]]
+
[[nl:Installatie FAQ]]
+
[[pt-br:FAQ Instalação]]
+
[[th:FAQ Installation]]
+
<!-- [[zh-cn:安装的常见问题]] -->
+

2021年8月29日 (日) 14:56時点における最新版

このページは https://ja.wordpress.org/support/article/faq-installation/ へ移動しました。