• 赤色のリンクは、まだ日本語Codexに存在しないページ・画像です。英語版と併せてご覧ください。(詳細

このWikiはいつでも誰でも編集できます

「テンプレート:サーバー要件」の版間の差分

提供: WordPress Codex 日本語版
移動先: 案内検索
(3.2: MySQL 5.0.15。コメントアウトされていた今後の予定を削除)
(最新情報を追加)
 
(2人の利用者による、間の4版が非表示)
1行目: 1行目:
 
<!-- include として使われているため、=== の見出しから始めています -->
 
<!-- include として使われているため、=== の見出しから始めています -->
=== バージョン 3.2 ===
+
=== 現在の最新版 ===
 +
 
 +
https://ja.wordpress.org/about/requirements/ を参照。
 +
 
 +
=== バージョン 5.2 系以降 ===
 +
* [[用語集#PHP|PHP]] バージョン 5.6.20 以上、ただし PHP 7 を強く推奨
 +
* [[用語集#MySQL|MySQL]] バージョン 5.0.15 以上または [[用語集#MariaDB|MariaDB]] (バージョン問わず)
 +
<noinclude>
 +
=== バージョン 3.2 系以降 ===
 
* [[用語集#PHP|PHP]] バージョン 5.2.4 以上
 
* [[用語集#PHP|PHP]] バージョン 5.2.4 以上
* [[用語集#MySQL|MySQL]] バージョン 5.0.15 以上
+
* [[用語集#MySQL|MySQL]] バージョン 5.0.15 以上または [[用語集#MariaDB|MariaDB]] (バージョン問わず)
  
 
=== バージョン 2.9〜3.1 系 ===
 
=== バージョン 2.9〜3.1 系 ===
 
* [[用語集#PHP|PHP]] バージョン 4.3 以上
 
* [[用語集#PHP|PHP]] バージョン 4.3 以上
 
* [[用語集#MySQL|MySQL]] バージョン 4.1.2 以上
 
* [[用語集#MySQL|MySQL]] バージョン 4.1.2 以上
<noinclude>
+
 
 
=== バージョン 2.5〜2.8 系 ===
 
=== バージョン 2.5〜2.8 系 ===
 
* [[用語集#PHP|PHP]] バージョン 4.3 以上
 
* [[用語集#PHP|PHP]] バージョン 4.3 以上
32行目: 40行目:
 
<noinclude>
 
<noinclude>
  
{{原文|Template:Server requirements|107444}}<!-- 15:30, 14 July 2011 MichaelH 版 -->
+
{{原文|Template:Server requirements|156400}}<!-- 13:08, 4 April 2016 Iangilfillan 版 -->
  
 
{{DEFAULTSORT:さあはようけん}}
 
{{DEFAULTSORT:さあはようけん}}
45行目: 53行目:
  
 
[[en:Template:Server requirements]]
 
[[en:Template:Server requirements]]
 +
[[fr:Template:fr:Exigences serveur]]
 +
[[it:Template:it:Requisiti del server]]
 
[[ru:Template:ru:Server_requirements]]
 
[[ru:Template:ru:Server_requirements]]
 +
[[tr:Template:tr:Sunucu gereksinimleri]]
 
</noinclude>
 
</noinclude>

2020年9月26日 (土) 14:11時点における最新版

現在の最新版

https://ja.wordpress.org/about/requirements/ を参照。

バージョン 5.2 系以降

  • PHP バージョン 5.6.20 以上、ただし PHP 7 を強く推奨
  • MySQL バージョン 5.0.15 以上または MariaDB (バージョン問わず)

バージョン 3.2 系以降

  • PHP バージョン 5.2.4 以上
  • MySQL バージョン 5.0.15 以上または MariaDB (バージョン問わず)

バージョン 2.9〜3.1 系

  • PHP バージョン 4.3 以上
  • MySQL バージョン 4.1.2 以上

バージョン 2.5〜2.8 系

  • PHP バージョン 4.3 以上
  • MySQL バージョン 4.0 以上[1]

バージョン 2.1~2.3 系

  • PHP バージョン 4.2 以上
  • MySQL バージョン 4.0 以上[1]

バージョン 2.0.x 系

  • PHP バージョン 4.2 以上
  • MySQL バージョン 3.23.23 以上[1]

共通オプション

上記すべてのバージョンに共通する、特定の機能を使う場合に必要なオプション。


脚注

  1. 1.0 1.1 1.2 確認されている制限事項: MySQL 4.0.x は UTF-8 に完全対応していないため、UTF-8 のブログで日本語によるサイト内検索やソートが正しく機能しないことがあります。WordPress 日本語版をお使いの場合は、バージョン 2.9 以前でも MySQL 4.1 以上の使用を推奨します。



最新英語版: WordPress Codex » Template:Server requirements最新版との差分