• 赤色のリンクは、まだ日本語Codexに存在しないページ・画像です。英語版と併せてご覧ください。(詳細

このWikiはいつでも誰でも編集できます

サーバーの用意

提供: WordPress Codex 日本語版
2014年6月8日 (日) 13:55時点におけるHeartyfluid (トーク | 投稿記録)による版 (PHP5.4以上を推奨する旨を追記)

移動先: 案内検索

WordPress は、たいていのホスティングサービス(レンタルサーバ)や、個人で立ち上げた Unix/Linux でのごく一般的な環境において設置が可能です。

  1. 転送 テンプレート:サーバー要件

おすすめは Apache または NGINX ウェブサーバの載った堅牢な Linux OS の構成です。PHPMySQL をサポートしているサーバであればほぼ確実に動作するはずです。あなたのサーバがこのプラットフォームと mod_rewrite をサポートしていない場合、これらを提供している ホスティングサービス(レンタルサーバ) に乗り換えたほうがいいでしょう。

サーバへのリモート接続が許可されていることも必須条件です。ホスティングサービスが外部に向けた HTTP 接続をブロックしている場合、WordPress でうまく動作しない部分がたくさんあるでしょう。

PHP 5.4 以上を推奨します。

推奨サーバ環境:

  • PHP バージョン 5.2 以上
  • MySQL バージョン 5.0 以上

参考

ホスティングサービス(レンタルサーバ)

最近はサーバスペースレンタルの需要が多いので、上記サーバ要件を満たすサーバを見つけやすくなりました。候補がほしいときは次のページからどうぞ。

最新英語版: WordPress Codex » Hosting WordPress最新版との差分