• 赤色のリンクは、まだ日本語Codexに存在しないページ・画像です。英語版と併せてご覧ください。(詳細

このWikiはいつでも誰でも編集できます

「サーバーの用意」の版間の差分

提供: WordPress Codex 日本語版
移動先: 案内検索
(MariaDB の記述などを更新。)
(要件の最新情報があるページヘのリンクと置き換え。)
 
1行目: 1行目:
 
{{スタートガイド|準備}}
 
{{スタートガイド|準備}}
  
WordPress は、たいていの[[用語集#Hosting provider|ホスティングサービス]](レンタルサーバ)や、個人で立ち上げた [[用語集#Unix|Unix]]/[[用語集#Linux|Linux]] でのごく一般的な環境において設置が可能です。
+
最新の要件については https://ja.wordpress.org/about/requirements/ をご覧ください。
 
+
<div id=" Server_requirements">
+
== サーバー要件 ==
+
</div>
+
 
+
{{サーバー要件}}
+
 
+
古い PHP や MySQL しか利用できないレガシーな環境でも、PHP 5.2.4 以上、かつ MySQL 5.0 以上であれば WordPress は動作しますが、公式サポートは終了しており、サイトがセキュリティの脆弱性にさらされる危険があります。このため、以下の推奨設定に従いホスティングサービスがサポートしている最新版の MySQL/MariaDB と PHP を使うことが最善です。
+
 
+
<div id="Recommended setup">
+
== 推奨構成 ==
+
</div>
+
 
+
おすすめは [[用語集#Apache|Apache]] または [http://nginx.net/ NGINX] ウェブサーバーの載った堅牢な [[用語集#Linux|Linux]] OS の構成です。[[用語集#PHP|PHP]] と [[用語集#MySQL|MySQL]]/[[用語集#MariaDB|MariaDB]] をサポートしているサーバーであればほぼ確実に動作するはずです。あなたのサーバがこのプラットフォームと <code>[[用語集#mod_rewrite|mod_rewrite]]</code> をサポートしていない場合、これらを提供している [[用語集#Hosting provider|ホスティングサービス]](レンタルサーバー) に乗り換えたほうがいいでしょう。
+
 
+
サーバーへのリモート接続が許可されていることも'''必須'''条件です。ホスティングサービスが外部に向けた HTTP 接続をブロックしている場合、WordPress でうまく動作しない部分がたくさんあるでしょう。
+
 
+
'''推奨サーバ環境:'''
+
* PHPバージョン 5.6 以上
+
* MySQL 5.6/MariaDB 10.0 以上
+
 
+
<div id="Hosting providers">
+
  
 
== ホスティングサービス(レンタルサーバー) ==
 
== ホスティングサービス(レンタルサーバー) ==

2020年9月26日 (土) 14:07時点における最新版

最新の要件については https://ja.wordpress.org/about/requirements/ をご覧ください。

ホスティングサービス(レンタルサーバー)

</div>

最近はサーバースペースレンタルの需要が多いので、上記サーバ要件を満たすサーバーを見つけやすくなりました。候補がほしいときは次のページからどうぞ。

最新英語版: WordPress Codex » Hosting WordPress最新版との差分