• 赤色のリンクは、まだ日本語Codexに存在しないページ・画像です。英語版と併せてご覧ください。(詳細

このWikiはいつでも誰でも編集できます

「サーバーの用意」の版間の差分

提供: WordPress Codex 日本語版
移動先: 案内検索
(PHP5.4以上を推奨する旨を追記)
(推奨構成: 推奨環境を更新)
20行目: 20行目:
  
 
'''推奨サーバ環境:'''
 
'''推奨サーバ環境:'''
* [[用語集#PHP|PHP]] バージョン 5.2 以上
+
* [[用語集#PHP|PHP]] バージョン 5.4 以上推奨
* [[用語集#MySQL|MySQL]] バージョン 5.0 以上
+
* [[用語集#MySQL|MySQL]] バージョン 5.5 以上推奨
 +
 
  
 
=== 参考 ===
 
=== 参考 ===
28行目: 29行目:
  
 
<div id="Hosting providers">
 
<div id="Hosting providers">
 +
 
== ホスティングサービス(レンタルサーバ) ==
 
== ホスティングサービス(レンタルサーバ) ==
 
</div>
 
</div>

2015年5月11日 (月) 21:40時点における版

WordPress は、たいていのホスティングサービス(レンタルサーバ)や、個人で立ち上げた Unix/Linux でのごく一般的な環境において設置が可能です。

  1. 転送 テンプレート:サーバー要件

おすすめは Apache または NGINX ウェブサーバの載った堅牢な Linux OS の構成です。PHPMySQL をサポートしているサーバであればほぼ確実に動作するはずです。あなたのサーバがこのプラットフォームと mod_rewrite をサポートしていない場合、これらを提供している ホスティングサービス(レンタルサーバ) に乗り換えたほうがいいでしょう。

サーバへのリモート接続が許可されていることも必須条件です。ホスティングサービスが外部に向けた HTTP 接続をブロックしている場合、WordPress でうまく動作しない部分がたくさんあるでしょう。

PHP 5.4 以上を推奨します。

推奨サーバ環境:

  • PHP バージョン 5.4 以上推奨
  • MySQL バージョン 5.5 以上推奨


参考

ホスティングサービス(レンタルサーバ)

最近はサーバスペースレンタルの需要が多いので、上記サーバ要件を満たすサーバを見つけやすくなりました。候補がほしいときは次のページからどうぞ。

最新英語版: WordPress Codex » Hosting WordPress最新版との差分